Linie Oben

Netzwerkprobleme

Linie unten

Nov. 2015

WLAN-Stick - Nein Danke!


Vor ein paar Monaten musste ich meinen Router wegen Umstiegs auf VoIP in die Diele neben der Telefonsteckdose platzieren, fernab von den Rechnern. Die DSL-Verbindung wurde sonst zu oft unterbrochen. Am einfachsten erschien es mir, das Heimnetz mit WLAN-USB-Sticks von Franz (Name geändert)  aufzubauen. Das funktionierte zunächst auch einwandfrei. Aber dann kamen die Probleme:

Beim Hochfahren:
  • Kein Internetzugriff (LAN-Netzwerksymbol mit gelben Dreieck)
  • WLAN-Verbindung wurde nicht aufgebaut (WLAN-Symbol mit rotem Kreuz)
  • Ein ständiges Ding-Dong Signal zeigte an, dass ein neues USB-Gerät erkannt wurde. Ziehen und Stecken des Stick wurde nötig (LAN-Netzwerksymbol mit rotem Kreuz).
  • Das WLAN-Symbole zeigte zwar an, dass die Internetverbindung bestand, der Browser und andere Programme hatten trotzdem keinen Internetzugang, obwohl ein Ping-Signal ins Netz Antwort bekam.
Beim Wakeup nach Standby
  • Hier die drei oben zuerst genannten Probleme
  • Es dauert lange Sekunden, bevor die WLAN-Verbindung wieder stand.
  • Es wurde nur das LAN-Netzwerksymbol angezeigt, obwohl die WLAN-Verbindung funktionierte.
Beim Neustart von Windows
  • Bluescreen mit der Meldung „WDF_VIOLATION(Treibername des WLAN-Sticks).

Ich konnte nicht feststellen, wo die Ursachen lagen, ob es Windows 10, Stick-Software, OpenVPN oder was auch immer war. Im Netz findet man auch viele Einträge anderer Anwender, die über gleiche Probleme berichten, ohne dass ich schließlich eine passende Lösung fand. Kontaktiert man die Hotline des Stick-Herstellers, wird man eine Woche lang mit Nachfragen beschäftigt, bis dann der geniale Rat kommt, den Treiber neu zu installieren, als ob man das nicht schon drei mal versucht hat.

Ich versuchte, durch Batches, welche über die Aufgabensteuerung beim Hochfahren / Wakeup gestartet wurden, die Probleme zu beheben und zwar mit den Befehlen:

devcon.exe rescan
devcon.exe disable „HWID des Sticks"
devcon.exe enable  „HWID des Sticks"
netsh wlan connect interface="WIFI-Name" name=netzname

Das funktionierte relativ gut,  jedoch trat auch jetzt immer wieder das Problem mit dem neu erkannten USB-Gerät (Ding-Dong-Signal) auf. Oder es dauerte relativ lange, bis endlich das WLAN-Symbol die bestehende Verbindung anzeigte.

Da reichte es mir. Weg damit, Schluss mit den Zicken! Die Lösung heißt:

dlan bzw. PowerLAN

Das Heimnetzwerk über die Steckdose. WIKIPEDIA

Adapter in die Steckdosen, Verschlüsselung nicht vergessen und dann Netzwerk über LAN-Kabel wie früher und alles funktioniert bestens. Zum Betrieb braucht man noch nicht mal einen zusätzlichen Treiber. Zur Verwaltung der Adapter kann man aber einen Monitor installieren.

Damit habe ich an dem gleichen Sicherungskreis die max. Adapterleistung von 500Mbit/sec über ca. 15 Meter Steckdosenleitung. Zur anderen Wohnungsseite  mit anderem Sicherungskreis sind es noch ca. 350Mbit/sec.  Das reicht für LAN mit 100Mbit/sec vollkommen aus. 

Hinweis: Offensichtlich verläuft die Kommunikation zwischen den Netzwerkrechnern direkt von Adapter zu Adapter, ohne über den Router zu laufen. Das kann man feststellen, indem man das LAN-Kabel am Router abzieht. Vermutlich wird die Netzwerkkonfiguration in die Adapter geladen, sobald sie in die Steckdose kommen. Das sollte man beachten, wenn man im Router die Netzwerkkonfiguration ändert: dann muss man die Adapter kurz stromlos machen. Durch diese direkte Kommunikation zwichen den Netzwerkrechnern findet der Datentransfer auch deutlich schneller statt als über die WLAN-Sticks. Die Geschwindigkeit entspricht die einer Cross-Over-Verbindung.

Nachdem sich die erste Euphorie gelegt hatte, zeigten sich auch hier Probleme:

  1. Die Adapter verlieren sporadisch nach Standby bzw. Shutdown und im laufenden Betrieb ihr „Gedächtnis", sie können keine Verbindung untereinander oder zum Internet herstellen. Nach den Meldungen im Internet sind davon auch Adapter anderer Hersteller betroffen.

  2. DIe Internetverbindung (DSL Speedtest) wird sehr langsam.

Abhilfe: Die Adapter kurz stromlos machen. Nicht nur lästig, sondern macht bei mir auch den angeschlossenen Router stromlos.

Vorbeugend kann man versuchen:

  1. dlan-Adapter: Stromsparfunktion deaktivieren. Hierbei bleiben die dlan-Adapter immer eingeschaltet, auch wenn der Rechner ausgeschaltet ist. Da Verbindungsabbrüche auch bei aktiven Adaptern auftreten, scheint dieses Maßnahme nicht sinnvoll zu sein.

  2. Netzwerkadapter-Adapter (Windows): Stromsparfunktion deaktivieren.

  3. Dauerping auf den Router: ping -t „Routername", eintragen in die Aufgabenverwaltung mit Trigger „beim Start". 

  4. Die Methode mit dem Dauer-Ping kann man natürlich nicht an einem zweiten Adapter anwenden, an dem nur TV-Geräte angeschlossen sind. Hier hilft nur: erst TV-Gerät einschalten, dann Adapter in die Steckdose, nicht umgekehrt.

 

Zur Stromsparfunktion: Nachdem ich ein Messgerät vor einen Adapter geschaltet habe, kam heraus, dass der Verbrauch im Ruhemodus mit deaktivierter Stromsparfunktion zwischen 1,0W und 1,5W schwankte, mit Stromsparmodus war er nicht erkennbar niedriger. Selbst im normalen Betrieb stieg der Verbrauch nicht über 2,5W.

1W bedeutet auf das Jahr hochgerechnet einen Verbrauch von 8,76 kWh. Stellt man das in Relation zu dem Jahresverbrauch eines Haushalts von wenigstens 1.500kWh, stellt sich die Frage, warum man hier sparen soll um den Preis der eingeschränkten Betriebssicherheit? Mir scheint, dass diese Stromsparfunktion nur ein Marketinggag für die Umweltschützer ist.  

 

Seitenanfang

Valid XHTML 1.0 Transitional

CSS ist valide!









.